<!DOCTYPE html>
<html>
<head>
<meta name="viewport" content="width=device-width, initial-scale=1">

<script type="text/javascript">
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function(){
       var gads = document.createElement("script");
        gads.async = true;
        gads.type = "text/javascript";
        var useSSL = "https:" == document.location.protocol;
        gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
        var node = document.getElementsByTagName("script")[0];
        node.parentNode.insertBefore(gads, node);
    })();
</script>

<script type='text/javascript'>
  var AdBridg = AdBridg || {};
  AdBridg.cmd = AdBridg.cmd || [];
  (function() {
      var adb = document.createElement("script");
      adb.async = true;
      adb.type = "text/javascript";
      adb.src = '//prod.adspsp.com/adb.2634970.min.js?cachebuster=1';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(adb, node);

      // Return control to GPT if the AdBridg library fails to load.
      adb.onerror = function() {
        console.log('Fallback: ')
        if (AdBridg.exists) { return; }
        document.createElement('IMG').src = '//adspsp.com/pt/2634970/3/1/?e=0';
        var dq = [], es;
        dq.process = function() { while(dq.length) { googletag.display(dq.shift()); }}
        AdBridg.defineSlot = function(p, s, d) { return googletag.defineSlot(p, s, d).addService(googletag.pubads()); }
        AdBridg.defineOutOfPageSlot = function(p, d) { return googletag.defineOutOfPageSlot(p, d).addService(googletag.pubads()); }
        AdBridg.destroySlots = function(s) { return googletag.destroySlots(s); }
        AdBridg.display = function(d) { dq.push(d); if (es) { dq.process(); }}
        AdBridg.refresh = function(s, o) { googletag.pubads().refresh(s, o); }
        AdBridg.render = function() { }
        AdBridg.serve = function() { googletag.enableServices(); es=1; dq.process(); }
        AdBridg.sizeMapping = function() { return googletag.sizeMapping(); }
        AdBridg.useSizeMapping = function() { }
        AdBridg.cmd.push = function(f) {
          if (typeof(f)=='object') {
            var api_fallback = function(o) {
              googletag.cmd.push(function() {
                var u=AdBridg.defineSlot(o.gpt_path,o.size||[],o.dom_id);
                if(o.size_map) {
                  var m = googletag.sizeMapping();
                  for(var oi=0;oi<o.size_map.length;oi++){m=m.addSize(o.size_map[oi].viewport, o.size_map[oi].sizes);}
                  u.defineSizeMapping(m.build());
                }
                if(o.events) {
                  if(o.events["gpt.defined"]){o.events["gpt.defined"](u);}
                  var fl = function(a,b){if(o.events[a]){googletag.pubads().addEventListener(b,function(e){if(e.slot===u){o.events[a](u,e)}})}}
                  fl("gpt.rendered",'slotRenderEnded');
                  fl("gpt.viewed",'impressionViewable');
                  fl("gpt.visibilityChanged",'slotVisibilityChanged');
                }
              });
            }
            if(f.length){for(var i=0;i<f.length;++i){api_fallback(f[i]);}}else{api_fallback(f);}
            f=function(){AdBridg.serve()}
          }
          return googletag.cmd.push(f);
        }
        while (AdBridg.cmd.length) { AdBridg.cmd.push(AdBridg.cmd.shift()); }
      }
  })();
</script>
<script>
AdBridg.cmd.push(function () {
	googletag.pubads().collapseEmptyDivs();
	googletag.pubads().setTargeting('articleid', ['50767']);
	googletag.pubads().setTargeting('Tag', ['articlepage','eagle london','g a y','sweatbox soho','whatsnew','travel news']);
	googletag.pubads().setTargeting('UGC', ['no']);
	
  });
</script>
<script>
var isHomePage = false;	
// -----------------------------------------------------------------------------------------
// Declare all ads that will be on page.
// -----------------------------------------------------------------------------------------
var gptAdSlots = {};
AdBridg.cmd.push([
		{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-leader1',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320, 100], [320, 50]] },
 { viewport: [729, 400], sizes:  [[728, 90]] },
 { viewport: [1000, 400], sizes:  [[728, 90], [970, 250], [970, 90], [970, 415]] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['Leader 1']);
		      gptAdSlots.leader1 = gpt_slot;
		    }
		  }
		},
					{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-box1',
		  size_map: [
		   { viewport: [0, 0], sizes: [[300, 250]] },
 { viewport: [729, 400], sizes:  [[300, 1050],[300, 600],[300, 250]] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['Box 1']);
		      gptAdSlots.box1 = gpt_slot;
		    }
		  }
		},
				{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-box2',
		  size_map: [
		   { viewport: [0, 0], sizes: [[300, 250]] },
 { viewport: [729, 400], sizes:  [[300, 1050],[300, 600],[300, 250]] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['Box 2']);
		      gptAdSlots.box2 = gpt_slot;
		    }
		  }
		},
				{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-box3',
		  size_map: [
		   { viewport: [0, 0], sizes: [[300, 250]] },
 { viewport: [729, 400], sizes:  [[300, 1050],[300, 600],[300, 250]] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['Box 3']);
		      gptAdSlots.box3 = gpt_slot;
		    }
		  }
		},
					{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-inarticle1',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320,100],[300, 250]] },
 { viewport: [729, 400], sizes:  [] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['In Article 1']);
		      gptAdSlots.inarticle1 = gpt_slot;
		    }
		  }
		},
				{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-inarticle2',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320,100],[300, 250]] },
 { viewport: [729, 400], sizes:  [] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['In Article 2']);
		      gptAdSlots.inarticle2 = gpt_slot;
		    }
		  }
		},
				{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-inarticle3',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320,100],[300, 250]] },
 { viewport: [729, 400], sizes:  [] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['In Article 3']);
		      gptAdSlots.inarticle3 = gpt_slot;
		    }
		  }
		},
				{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-inarticle4',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320,100],[300, 250]] },
 { viewport: [729, 400], sizes:  [] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['In Article 4']);
		      gptAdSlots.inarticle4 = gpt_slot;
		    }
		  }
		},
				{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-inarticle5',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320,100],[300, 250]] },
 { viewport: [729, 400], sizes:  [] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['In Article 5']);
		      gptAdSlots.inarticle5 = gpt_slot;
		    }
		  }
		},
				{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-inarticle6',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320,100],[300, 250]] },
 { viewport: [729, 400], sizes:  [] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['In Article 6']);
		      gptAdSlots.inarticle6 = gpt_slot;
		    }
		  }
		},
					{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-inline1',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320,100],[320, 50]] },
 { viewport: [729, 400], sizes:  [] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['Inline 1']);
		      gptAdSlots.inline1 = gpt_slot;
		    }
		  }
		},
				
]);	//close ad units cmd.push
</script><title>Gay bathhouse blasts other venues as “immoral” for staying open / GayCities Blog</title>
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//www.gaycities.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="GayCities Blog &raquo; Feed" href="https://www.gaycities.com/outthere/feed/" />
<link rel="alternate" type="application/rss+xml" title="GayCities Blog &raquo; Comments Feed" href="https://www.gaycities.com/outthere/comments/feed/" />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.gaycities.com/outthere/wp/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css-css' href='https://www.gaycities.com/outthere/content/themes/gaycities_2017/fonts/font-awesome-4.7.0/font-awesome.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='gaycities-site-style-css' href='https://www.gaycities.com/css/style.css?ver=20200305b' type='text/css' media='all' />
<link rel='stylesheet' id='gaycities_2017-style-css' href='https://www.gaycities.com/outthere/content/themes/gaycities_2017/style.css?ver=20200305b' type='text/css' media='all' />
<script type='text/javascript' src='https://www.gaycities.com/outthere/wp/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.gaycities.com/outthere/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://cdn.jsdelivr.net/jquery.slick/1.6.0/slick.min.js?ver=20170107'></script>
<link rel='prev' title='GayCities is searching for the next travel pics superstar—could it be you?' href='https://www.gaycities.com/outthere/50760/gaycities-is-searching-for-the-next-travel-pics-superstar-could-it-be-you/' />
<link rel="canonical" href="https://www.gaycities.com/outthere/50767/gay-bathhouse-blasts-other-venues-as-immoral-for-staying-open/" />
<meta property="og:site_name" content="GayCities Blog" /> <meta name="description" content="London, England is not yet in lockdown because of COVID-19 but many LGBTQ spaces have chosen to close..." />
<meta property="og:description" content="London, England is not yet in lockdown because of COVID-19 but many LGBTQ spaces have chosen to close...">
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.gaycities.com/outthere/50767/gay-bathhouse-blasts-other-venues-as-immoral-for-staying-open/" />
<meta property="og:title" content="Gay bathhouse blasts other venues as “immoral” for staying open" />
<meta property="og:image" content="https://gaycities-blog-prodweb.imgix.net/outthere/content/uploads/2020/03/eagle_london_vauxhall.jpg?fit=crop&auto=format&auto=compress&crop=faces" />
<meta property="og:image:width" content="1203" />
<meta property="og:image:height" content="675" />
<meta name="twitter:image" content="https://gaycities-blog-prodweb.imgix.net/outthere/content/uploads/2020/03/eagle_london_vauxhall.jpg?fit=crop&auto=format&auto=compress&crop=faces" />
<meta property="article:published_time" content="2020-03-19T05:23:26-04:00" />
<meta property="article:modified_time" content="2020-03-19T05:23:28-04:00" />
<meta name="twitter:url" content="https://www.gaycities.com/outthere/50767/gay-bathhouse-blasts-other-venues-as-immoral-for-staying-open/" />
<meta name="twitter:title" content="Gay bathhouse blasts other venues as “immoral” for staying open" />
<meta name="twitter:description" content="London, England is not yet in lockdown because of COVID-19 but many LGBTQ spaces have chosen to close..." />
<meta name="news_keywords" content="Eagle London, G-A-Y, Sweatbox Soho"><meta property="article:tags" content="Eagle London, G-A-Y, Sweatbox Soho"><meta name="author" property="author" content="David Hudson" /> 
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-KXLC6M6');</script>

<link rel="amphtml" href="https://www.gaycities.com/outthere/50767/gay-bathhouse-blasts-other-venues-as-immoral-for-staying-open/amp/"> <meta property="fb:app_id" content="203568195269" />
<meta property="article:publisher" content="http://www.facebook.com/gaycities" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@gaycities" />
<script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://markedmeasure.com/v2/0/vtaz0c9vmNOh7yu_X6KcpGqLci_kHVGVFp9XTTf3fse1j06C4aiWgM",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;!(function(t,n,i,u,e,o){var a=n[i];function r(t){if(t){var u=(t.data||{})[i+"Call"];u&&n[i](u.command,u.version,function(n,i){t.source.postMessage({__uspapiReturn:{returnValue:n,success:i,callId:u.callId}},"*")})}}if((function c(){if(!window.frames[u]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=u,n.appendChild(i)}else setTimeout(c,5)}})(),"function"!=typeof a){var s={getUSPData:function(n,i){return n!==1?i&&i(null,!1):i&&i({version:null,uspString:null},!1)}};a=n[i]=function(n,i,t){return s[n](i,t)},n.addEventListener?n.addEventListener("message",r,!1):n.attachEvent&&n.attachEvent("onmessage",r)}o=t.createElement(e),t=t.getElementsByTagName(e)[0],o.src="https://markedmeasure.com/v2/0/xvf6BUYmr0GbZw6KPi1vcS9YTQbTPBzUNpbNcIPXmqBh-M8GZwhCZ2Y0hpMnlx_EgihSuKp",t.parentNode.insertBefore(o,t)})(document,window,"__uspapi","__uspapiLocator","script");</script>
<meta name="apple-itunes-app" content="app-id=303661699">
<meta name="apple-mobile-web-app-title" content="gaycities">
<meta name="application-name" content="GayCities">
<meta name="theme-color" content="#ffffff">
</head>
<body class="post-template-default single single-post postid-50767 single-format-standard category-whatsnew category-travel-news">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KXLC6M6"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div id="page" class="site">
<div class="gaycities-header-ad" id="div-gpt-ad-leader1">
<script>
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-leader1'); });
				</script>
</div>

<div id="is-phone"></div>
<header class="site-header" role="banner">
<div class="top-navigation">
<div class="site-header-inner-wrap">
<nav class="site-header-inner clearfix">
<a class="logo" href="https://www.gaycities.com">
<img src="https://www.gaycities.com/images/gaycities-logo.svg" alt="GayCities Gay Travel Guides">
</a>
<div class="caret-wrapper">
<span class="caret" data-dropdown="toggle" aria-haspopup="true" aria-expanded="false" aria-controls="mobile-dropdown-menu"></span>
</div>
<ul class="header-left-nav">
<li><a href="https://www.gaycities.com/places" class="">Cities</a></li>
<li><a href="https://www.gaycities.com/articles" class="selected">Articles</a></li>
<li><a href="https://www.gaycities.com/photos">Photos</a></li>
</ul>
<ul class="mobile-dropdown-menu" id="mobile-dropdown-menu" data-dropdown="menu" aria-hidden="true" aria-label="User Account Dropdown Menu">
<li><a href="https://www.gaycities.com">Home</a></li>
<li><hr></li>
<li><a href="https://www.gaycities.com/places" class="">Cities</a></li>
<li><a href="https://www.gaycities.com/articles" class="selected">Articles</a></li>
<li><a href="https://www.gaycities.com/photos">Photos</a></li>
<li><hr></li>
<li><a href="https://www.gaycities.com/login">Sign In</a></li>
<li><a href="https://www.gaycities.com/register">Register</a></li>
</ul>
</nav>
</div>
</div>
</header>
<div id="content" class="site-content"> <div id="primary" class="content-area single-article">
<main id="main" class="site-main" role="main">
<article id="post-50767" class="post-50767 post type-post status-publish format-standard has-post-thumbnail hentry category-whatsnew category-travel-news tag-eagle-london tag-g-a-y tag-sweatbox-soho">
<header class="entry-header">
<h1 class="entry-title"><a href="https://www.gaycities.com/outthere/50767/gay-bathhouse-blasts-other-venues-as-immoral-for-staying-open/">Gay bathhouse blasts other venues as “immoral” for staying open</a></h1>
<div class="entry-meta">
<span class="byline"> By <a href="https://www.gaycities.com/outthere/author/david-hudson/" title="Posts by David Hudson" rel="author">David Hudson</a></span> <time class="posted-on" datetime="2020-03-19T05:23:26-04:00">9 hours ago</time> </div>
</header>
<div class="entry-content">
<script data-cfasync="false" type="text/javascript" class="teads" async="true" src="//a.teads.tv/page/74317/tag"></script><script data-cfasync="false" src="//a.teads.tv/media/format/v3/teads-format.min.js"></script><figure class="wp-block-image size-large"><img src="https://s3.amazonaws.com/gaycities-blog-prodweb/outthere/content/uploads/2020/03/eagle_london_vauxhall-1024x575.jpg" alt="Eagle London" class="wp-image-50768" srcset="https://s3.amazonaws.com/gaycities-blog-prodweb/outthere/content/uploads/2020/03/eagle_london_vauxhall-1024x575.jpg 1024w, https://s3.amazonaws.com/gaycities-blog-prodweb/outthere/content/uploads/2020/03/eagle_london_vauxhall-550x309.jpg 550w, https://s3.amazonaws.com/gaycities-blog-prodweb/outthere/content/uploads/2020/03/eagle_london_vauxhall-768x431.jpg 768w, https://s3.amazonaws.com/gaycities-blog-prodweb/outthere/content/uploads/2020/03/eagle_london_vauxhall-396x222.jpg 396w, https://s3.amazonaws.com/gaycities-blog-prodweb/outthere/content/uploads/2020/03/eagle_london_vauxhall.jpg 1203w" sizes="(max-width: 1024px) 100vw, 1024px"><figcaption>Eagle London was one of the first UK venues to shut its doors (Photo: Eagle London)</figcaption></figure><p><a href="https://london.gaycities.com/bathhouses/306039-sweatbox">Sweatbox</a>, a gay bathhouse in <a href="https://london.gaycities.com/">London</a>, UK, has shut its doors because of the coronavirus pandemic. Its owners stated that they felt it would be “highly immoral” to remain open.</p>
<p>At the time of writing, the UK capital is not in lockdown. Pubs, clubs and restaurants are allowed to stay open if they decide to do so. However, on Monday, the Prime Minister, Boris Johnson, advised the public not to go to bars and restaurants and to practice social distancing.</p>
<p>This led many of London’s LGBTQ venues in a quandary: to remain open or choose to close?</p><div class="ad-300 inline" id="div-gpt-ad-inarticle1"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle1"); });</script></div>
<p><strong>Related: <a href="https://www.gaycities.com/outthere/50698/covid-19-new-york-city-and-los-angeles-close-all-bars-and-restaurants/">New York City and Los Angeles close all bars and restaurants</a></strong></p>
<p>Some famed gay venues in the city had already decided to suspend operations until the crisis abates. This included <a href="https://london.gaycities.com/bars/1685-eagle-london">Eagle London</a> in South London, which posted a message to its social media on Sunday stating: “With the steady rise in cases and the stress on the health system we feel the time is right to protect our customers and staff from this ongoing threat and close the venue.”</p>
<p>On Tuesday, Jeremy Joseph, promoter of London’s biggest gay club, <a rel="noreferrer noopener" aria-label="G-A-Y (opens in a new tab)" href="https://london.gaycities.com/bars/1692-g-a-y-at-heaven" target="_blank">G-A-Y</a>, blasted the Prime Minister as a “c*nt”. He and others felt that warning the public to avoid bars without ordering venues to close meant they faced potential financial ruin and would not be able to claim on their insurance policies or state-assisted sick pay.</p>
<p>“BORIS JOHNSON – YOU ARE A C*NT,” Joseph wrote on <a href="https://www.facebook.com/jeremy.joseph.334/posts/3273477006016483" target="_blank" rel="noreferrer noopener" aria-label="Facebook (opens in a new tab)">Facebook</a>. “Telling People to avoid pubs, restaurants &amp; theatres but not closing them, in other words, Unofficially closing venues but making sure Government isn’t liable for staff To get sick pay.”</p><div class="ad-300 inline" id="div-gpt-ad-inarticle2"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle2"); });</script></div>
<p>This was followed by G-A-Y announcing it was closing its venues, which include the G-A-Y Bar in Soho and G-A-Y Late. Joseph employs around 200 people across his four venues in the UK (he also has a bar in <a href="https://manchester.gaycities.com/">Manchester</a>).</p>
<p>The government has since <a href="https://www.bbc.com/news/business-51935467" target="_blank" rel="noreferrer noopener" aria-label="announced (opens in a new tab)">announced</a> some grants and loans for small businesses struggling to cope in the wake of the pandemic.</p>
<p>On Tuesday, Sweatbox, which operates a gay gym and sauna in central London, announced it was closing. The venue underwent an extensive refit last year costing hundreds of thousands of dollars.</p><div class="ad-300 inline" id="div-gpt-ad-inarticle3"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle3"); });</script></div>
<figure class="wp-block-embed-instagram wp-block-embed is-type-rich is-provider-instagram"><div class="wp-block-embed__wrapper">
<div class=""><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B5FLpkVFW_Q/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/B5FLpkVFW_Q/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> <div style=" display: flex; flex-direction: row; align-items: center;"> <div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div> <div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div> <div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewbox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"> <div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div> <div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div> <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div> <div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div> <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"> <div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div> <div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"> <div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div> <div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div> <div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div></a> <p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B5FLpkVFW_Q/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">On Wednesdays we wear wraps… photo by @original_matt_spike</a></p> <p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/sweatboxsoho/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> SweatBox Soho</a> (@sweatboxsoho) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2019-11-20T08:43:42+00:00">Nov 20, 2019 at 12:43am PST</time></p></div></blockquote><script async src="//www.instagram.com/embed.js"></script></div>
</div></figure><p>“It is with great regret, sadness and a lot of anxiety that Sweatbox has felt compelled to close its doors to the public until such time as the policy of Social Distancing has been lifted,” it <a href="https://www.facebook.com/SweatBoxSoho/photos/a.740266162971019/1153255081672123/?type=3&amp;theater" target="_blank" rel="noreferrer noopener" aria-label="stated (opens in a new tab)">stated</a> on social media.</p>
<p>“Whilst we may not agree with the way the government has handled it, we do believe the science. The nature of gay saunas are specifically non-conducive to Social Distancing. Far more so than even pubs or cinemas. Therefore, we think it would be highly immoral to remain open during this time.”</p>
<p>It went on to say, “The effects of this closure are devastating on both the business and our staff. But this is a crisis of unparalleled proportions. We will be fighting tooth and nail for both the survival of our business and the welfare of our staff.”</p><div class="ad-300 inline" id="div-gpt-ad-inarticle4"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle4"); });</script></div>
<p><strong>Related: <a href="https://www.queerty.com/lgbtq-people-heightened-risk-coronavirus-warn-advocacy-groups-20200312" target="_blank" rel="noreferrer noopener" aria-label="LGBTQ people at heightened risk from coronavirus, warn advocacy groups (opens in a new tab)">LGBTQ people at heightened risk from coronavirus, warn advocacy groups</a></strong></p>
<p>Although Sweatbox was the first gay bathhouse in London to announce its closure, it was followed yesterday by statements from Pleasuredrome, Chariots Vauxhall and Sailors Sauna that they too were closing. No closures statements have yet been posted by Locker Room sauna in south London or E15 Club in East London.</p>
<p>Many other gay venues have announced they are now closed, including <a rel="noreferrer noopener" aria-label="The Glory (opens in a new tab)" href="https://london.gaycities.com/bars/306128-the-glory" target="_blank">The Glory</a> and <a href="https://london.gaycities.com/bars/2308-dalston-superstore">Dalston Superstore</a> in East London. The <a href="https://london.gaycities.com/bars/1710-the-royal-vauxhall-tavern-aka-the-rvt">Royal Vauxhall Tavern</a>, another of London’s most famed venues, has indicated it will <a rel="noreferrer noopener" aria-label="remain open (opens in a new tab)" href="https://www.facebook.com/TheRVT/posts/10157988656557789?__xts__%5B0%5D=68.ARD6cHbS9GozOMzcCLsmWh6mMMUFzOvzTAc9ceNP1KSvlCWoUid5Qs9Qy1a2VNM0CSOeVqOJoTk5wYiO84XdaZr8ub5-7oCxCHKNQpapKOX2GyFnsBBIK-6a2kUXZtpCETRmErS1-dk9Rj_3fQjnkYVtEI_EnXJwAnVsh90hxK2cl7MONU8tndfNakaTbzMo1XZVtcjNkPZ8qGBv8wN0lKcahQ-Oa43v3p-HsEKIXLnmvPdZwlsVjq70nlZqQQ2Gtvi8eG5HgFscwyMyzGfw22UbxUOche61uld7hhuoYsPjd15npSGrpXcnqXBFfR-aUY9-VPZIbTw&amp;__tn__=-R" target="_blank">remain open</a> unless forced to close.</p><div class="ad-300 inline" id="div-gpt-ad-inarticle5"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle5"); });</script></div>
<p>In the UK, at the time of writing, there have been over 2,000 confirmed cases of COVID-19 and just over 100 deaths. The majority of cases are in London, with over 900 cases and 34 deaths. Health experts believe the true figure of those infected in the UK could be 55,000, but many have not been tested or are not showing symptoms.</p>
<p>Transport for London (TfL) has announced it is <a rel="noreferrer noopener" aria-label="reducing services (opens in a new tab)" href="https://www.bbc.com/news/uk-england-london-51946409" target="_blank">reducing services</a> and closing 40 tube stations. There is speculation the capital may be forced into lockdown over the coming days. In the US, major cities including New York, Los Angeles and San Francisco have ordered the closure of bars and restaurants.</p>
</div>
<footer class="entry-footer">
<span class="tags-links"><a href="https://www.gaycities.com/outthere/tag/eagle-london/" rel="tag">Eagle London</a> <a href="https://www.gaycities.com/outthere/tag/g-a-y/" rel="tag">G-A-Y</a> <a href="https://www.gaycities.com/outthere/tag/sweatbox-soho/" rel="tag">Sweatbox Soho</a></span> </footer>
</article>
<div class="mobile-ad-leader" id="div-gpt-ad-inline1">
<script>
	AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-inline1'); });
	</script>
</div>
<div class="fb-comments" data-href="https://www.gaycities.com/outthere/50767/gay-bathhouse-blasts-other-venues-as-immoral-for-staying-open/" data-numposts="10"></div>
</main>
</div>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-596fbbbe85709b4a"></script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.gaycities.com\/outthere\/50767\/gay-bathhouse-blasts-other-venues-as-immoral-for-staying-open\/"},"headline":"Gay bathhouse blasts other venues as \u201cimmoral\u201d for staying open","url":"https:\/\/www.gaycities.com\/outthere\/50767\/gay-bathhouse-blasts-other-venues-as-immoral-for-staying-open\/","datePublished":"2020-03-19T05:23:26-04:00","dateModified":"2020-03-19T05:23:28-04:00","description":"London, England is not yet in lockdown because of COVID-19 but many LGBTQ spaces have chosen to close","thumbnailUrl":"https:\/\/s3.amazonaws.com\/gaycities-blog-prodweb\/outthere\/content\/uploads\/2020\/03\/eagle_london_vauxhall-396x222.jpg","image":{"@type":"ImageObject","url":"https:\/\/s3.amazonaws.com\/gaycities-blog-prodweb\/outthere\/content\/uploads\/2020\/03\/eagle_london_vauxhall-396x222.jpg","height":872,"width":490},"creator":"David Hudson","author":{"@type":"Person","name":"David Hudson"},"articleSection":"Articles","keywords":["Travel News","Eagle London","G-A-Y","Sweatbox Soho","[ Has: Instagram embed ]","[ Word count: 600-1000 ]"],"publisher":{"@type":"NewsMediaOrganization","name":"Queerty","url":"https:\/\/www.gaycities.com\/","logo":{"@type":"ImageObject","url":"https:\/\/www.gaycities.com\/images\/gaycities-logo-blue.png","height":"198","width":"855"},"address":{"@type":"PostalAddress","streetAddress":"584 Castro St. #623","addressLocality":"San Francisco","addressRegion":"CA","postalCode":"94114","addressCountry":"USA"},"sameAs":["https:\/\/www.facebook.com\/gaycities","https:\/\/www.twitter.com\/gaycities","https:\/\/www.instagram.com\/gaycities"]}}</script>
<aside id="secondary" class="article-sidebar" role="complementary">
<div class="sidebar-ad-1" id="div-gpt-ad-box1">
<script>
			googletag.cmd.push(function() { googletag.display('div-gpt-ad-box1'); });
			</script>
</div>
<section class="sidebar-related">
<h3 class="category-heading">
More GayCities </h3>
<div class="cards-list">
<article id="post-50760" class="card card-small ">
<a href="https://www.gaycities.com/outthere/50760/gaycities-is-searching-for-the-next-travel-pics-superstar-could-it-be-you/">
<section class="card-thumb">
<img src="https://gaycities-blog-prodweb.imgix.net/outthere/content/uploads/2020/03/sunga.jpg?fit=crop&auto=format&auto=compress&crop=faces&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">GayCities is searching for the next travel pics superstar—could it be you?</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/50760/gaycities-is-searching-for-the-next-travel-pics-superstar-could-it-be-you/" rel="bookmark"><time class="entry-date published updated" datetime="2020-03-18T17:43:54-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-50739" class="card card-small ">
<a href="https://www.gaycities.com/outthere/50739/the-key-to-being-a-trans-ally-we-dont-want-to-be-treated-different/">
<section class="card-thumb">
<img src="https://gaycities-blog-prodweb.imgix.net/outthere/content/uploads/2020/03/Heavenly_bodies_the_abbey.jpg?fit=crop&auto=format&auto=compress&crop=faces&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">The key to being a trans ally: &#8216;We don&#8217;t want to be treated different&#8217;</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-50710" class="card card-small ">
<a href="https://www.gaycities.com/outthere/50710/winter-party-attendee-tested-positive-with-coronavirus/">
<section class="card-thumb">
<img src="https://gaycities-blog-prodweb.imgix.net/outthere/content/uploads/2020/03/winter_party_miami-1.jpg?fit=crop&auto=format&auto=compress&crop=faces&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">Winter Party attendee tested positive for coronavirus</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/50710/winter-party-attendee-tested-positive-with-coronavirus/" rel="bookmark"><time class="entry-date published updated" datetime="2020-03-16T10:52:17-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-50698" class="card card-small ">
<a href="https://www.gaycities.com/outthere/50698/covid-19-new-york-city-and-los-angeles-close-all-bars-and-restaurants/">
<section class="card-thumb">
<img src="https://gaycities-blog-prodweb.imgix.net/outthere/content/uploads/2020/03/stonewall_inn_david_hudson_1200.jpg?fit=crop&auto=format&auto=compress&crop=faces&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">New York City and Los Angeles close all bars and restaurants</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/50698/covid-19-new-york-city-and-los-angeles-close-all-bars-and-restaurants/" rel="bookmark"><time class="entry-date published updated" datetime="2020-03-16T04:38:19-04:00"></time></a> </div>
</section>
</a>
</article>
</div>
</section>
<div class="sidebar-ad-2" id="div-gpt-ad-box2">
<script>
			googletag.cmd.push(function() { googletag.display('div-gpt-ad-box2'); });
			</script>
</div>
<div id="civsci-id-109286964" data-civicscience-widget="a8ff42a5-6a5e-8114-ed3f-8851c8882960"></div>
<script type="text/javascript" async src="https://www.civicscience.com/jspoll/4/civicscience-widget.js"></script>
</aside>
<br clear=all>
<div class="single-bottom-articles">
<h3>
Latest Travel Articles on GayCities </h3>
<div class="single-bottom-articles-slider slider slick-slider">
<div>
<article id="post-50760" class="card card-small ">
<a href="https://www.gaycities.com/outthere/50760/gaycities-is-searching-for-the-next-travel-pics-superstar-could-it-be-you/">
<section class="card-thumb">
<img src="https://gaycities-blog-prodweb.imgix.net/outthere/content/uploads/2020/03/sunga.jpg?fit=crop&auto=format&auto=compress&crop=faces&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">GayCities is searching for the next travel pics superstar—could it be you?</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/50760/gaycities-is-searching-for-the-next-travel-pics-superstar-could-it-be-you/" rel="bookmark"><time class="entry-date published updated" datetime="2020-03-18T17:43:54-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div>
<article id="post-50739" class="card card-small ">
<a href="https://www.gaycities.com/outthere/50739/the-key-to-being-a-trans-ally-we-dont-want-to-be-treated-different/">
<section class="card-thumb">
<img src="https://gaycities-blog-prodweb.imgix.net/outthere/content/uploads/2020/03/Heavenly_bodies_the_abbey.jpg?fit=crop&auto=format&auto=compress&crop=faces&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">The key to being a trans ally: &#8216;We don&#8217;t want to be treated different&#8217;</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div>
<article id="post-50710" class="card card-small ">
<a href="https://www.gaycities.com/outthere/50710/winter-party-attendee-tested-positive-with-coronavirus/">
<section class="card-thumb">
<img src="https://gaycities-blog-prodweb.imgix.net/outthere/content/uploads/2020/03/winter_party_miami-1.jpg?fit=crop&auto=format&auto=compress&crop=faces&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">Winter Party attendee tested positive for coronavirus</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/50710/winter-party-attendee-tested-positive-with-coronavirus/" rel="bookmark"><time class="entry-date published updated" datetime="2020-03-16T10:52:17-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div>
<article id="post-50698" class="card card-small ">
<a href="https://www.gaycities.com/outthere/50698/covid-19-new-york-city-and-los-angeles-close-all-bars-and-restaurants/">
<section class="card-thumb">
<img src="https://gaycities-blog-prodweb.imgix.net/outthere/content/uploads/2020/03/stonewall_inn_david_hudson_1200.jpg?fit=crop&auto=format&auto=compress&crop=faces&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">New York City and Los Angeles close all bars and restaurants</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/50698/covid-19-new-york-city-and-los-angeles-close-all-bars-and-restaurants/" rel="bookmark"><time class="entry-date published updated" datetime="2020-03-16T04:38:19-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div>
<article id="post-50623" class="card card-small ">
<a href="https://www.gaycities.com/outthere/50623/i-was-catfished-by-sherry-pie-then-i-became-a-joke-on-the-wendy-williams-show/">
<section class="card-thumb">
<img src="https://gaycities-blog-prodweb.imgix.net/outthere/content/uploads/2020/03/sherry_pie_drag_race.jpg?fit=crop&auto=format&auto=compress&crop=faces&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">I was &#8216;catfished&#8217; by Sherry Pie, then I became a joke on &#8216;The Wendy Williams Show&#8217;</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div>
<article id="post-50572" class="card card-small ">
<a href="https://www.gaycities.com/outthere/50572/open-letter-sf-queen-juanita-more-responds-to-the-pandemic/">
<section class="card-thumb">
<img src="https://gaycities-blog-prodweb.imgix.net/outthere/content/uploads/2020/03/unnamed-4.jpg?fit=crop&auto=format&auto=compress&crop=faces&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">Open Letter: SF queen Juanita MORE! responds to the pandemic</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/50572/open-letter-sf-queen-juanita-more-responds-to-the-pandemic/" rel="bookmark"><time class="entry-date published updated" datetime="2020-03-13T21:34:19-04:00"></time></a> </div>
</section>
</a>
</article>
</div>
</div>
</div>
</div>
<div class="site-footer-holder">
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="footer-links">
<ul class="main" id="footer-company-links">
<li><a href="https://www.q.digital"><img src="https://dxepcgbfdydik.cloudfront.net/assets/q-digital-blue-90x37.png" alt="Q.Digital" width="90"></a></li>
<li><b>A Q.Digital Company</b></li>
<li>&copy; 2020 GayCities, Inc.</li>
<li><a href="https://www.q.digital">Advertise With Us</a></li>
</ul>
<ul class="main" id="footer-contact-links">
<li><a href="https://www.gaycities.com/about/privacy">Privacy Policy</a>
<li><a href="https://www.gaycities.com/about/termsofuse">Terms of Use</a>
</ul>
<ul class="main" id="footer-follow-links">
<li><h3>Follow</h3></li>
<li><a href="https://www.facebook.com/GayCities/">Facebook</a></li>
<li><a href="https://www.twitter.com/GayCities/">Twitter</a></li>
<li><a href="https://www.instagram.com/GayCities/">Instagram</a></li>
</ul>
<ul class="main double" id="footer-gaycities-links">
<li><h3>GayCities: The best of what's happening in:</h3></li>
<li><a href="https://newyork.gaycities.com/">New York</a></li>
<li><a href="https://sanfrancisco.gaycities.com/">San Francisco</a></li>
<li><a href="https://chicago.gaycities.com/">Chicago</a></li>
<li><a href="https://losangeles.gaycities.com/">Los Angeles</a></li>
<li><a href="https://washingtondc.gaycities.com/">Washington DC</a></li>
<li><a href="https://dallas.gaycities.com/">Dallas</a></li>
<li><a href="https://london.gaycities.com/">London</a></li>
<li><a href="https://www.gaycities.com/places/"><b>See all 225+ cities...</b></a></li>
</ul>
</div>
</footer>
</div>
</div>

<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "32666898" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=32666898&cv=2.0&cj=1" alt="Comscore Measurement" />
</noscript>

<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '686853021424163');
  fbq('track', 'PageView');
</script>
<noscript><img height='1' width='1' style='display:none'
  src='https://www.facebook.com/tr?id=686853021424163&ev=PageView&noscript=1'
/></noscript>

<script>
  fbq('track', 'ViewContent');
</script>
<script type='text/javascript' src='https://www.gaycities.com/outthere/content/themes/gaycities_2017/js/gaycities-main-min.js?ver=20170926'></script>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=20161216'></script>
<script type='text/javascript' src='https://www.gaycities.com/outthere/wp/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<div id="fb-root"></div>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.3&appId=203568195269&autoLogAppEvents=1"></script>
<script data-cfasync="false" id="parsely-cfg" data-parsely-site="gaycities.com" src="https://cdn.parsely.com/keys/gaycities.com/p.js"></script>
</body>
</html>