<!DOCTYPE html>
<html>
<head>
<meta name="viewport" content="width=device-width, initial-scale=1">

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
</script>

<script type='text/javascript'>
  var AdBridg = AdBridg || {};
  AdBridg.cmd = AdBridg.cmd || [];
  (function() {
      var adb = document.createElement("script");
      adb.async = true;
      adb.type = "text/javascript";
      adb.src = '//prod.adspsp.com/adb.2634970.min.js?cachebuster=1';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(adb, node);

      // Return control to GPT if the AdBridg library fails to load.
      adb.onerror = function() {
        console.log('Fallback: ')
        if (AdBridg.exists) { return; }
        document.createElement('IMG').src = '//adspsp.com/pt/2634970/3/1/?e=0';
        var dq = [], es;
        dq.process = function() { while(dq.length) { googletag.display(dq.shift()); }}
        AdBridg.defineSlot = function(p, s, d) { return googletag.defineSlot(p, s, d).addService(googletag.pubads()); }
        AdBridg.defineOutOfPageSlot = function(p, d) { return googletag.defineOutOfPageSlot(p, d).addService(googletag.pubads()); }
        AdBridg.destroySlots = function(s) { return googletag.destroySlots(s); }
        AdBridg.display = function(d) { dq.push(d); if (es) { dq.process(); }}
        AdBridg.refresh = function(s, o) { googletag.pubads().refresh(s, o); }
        AdBridg.render = function() { }
        AdBridg.serve = function() { googletag.enableServices(); es=1; dq.process(); }
        AdBridg.sizeMapping = function() { return googletag.sizeMapping(); }
        AdBridg.useSizeMapping = function() { }
        AdBridg.cmd.push = function(f) {
          if (typeof(f)=='object') {
            var api_fallback = function(o) {
              googletag.cmd.push(function() {
                var u=AdBridg.defineSlot(o.gpt_path,o.size||[],o.dom_id);
                if(o.size_map) {
                  var m = googletag.sizeMapping();
                  for(var oi=0;oi<o.size_map.length;oi++){m=m.addSize(o.size_map[oi].viewport, o.size_map[oi].sizes);}
                  u.defineSizeMapping(m.build());
                }
                if(o.events) {
                  if(o.events["gpt.defined"]){o.events["gpt.defined"](u);}
                  var fl = function(a,b){if(o.events[a]){googletag.pubads().addEventListener(b,function(e){if(e.slot===u){o.events[a](u,e)}})}}
                  fl("gpt.rendered",'slotRenderEnded');
                  fl("gpt.viewed",'impressionViewable');
                  fl("gpt.visibilityChanged",'slotVisibilityChanged');
                }
              });
            }
            if(f.length){for(var i=0;i<f.length;++i){api_fallback(f[i]);}}else{api_fallback(f);}
            f=function(){AdBridg.serve()}
          }
          return googletag.cmd.push(f);
        }
        while (AdBridg.cmd.length) { AdBridg.cmd.push(AdBridg.cmd.shift()); }
      }
  })();
</script>
<script>
AdBridg.cmd.push(function () {
	googletag.pubads().collapseEmptyDivs();
	googletag.pubads().setTargeting('articleid', ['53342']);
	googletag.pubads().setTargeting('Tag', ['articlepage','florida','hg roosters','west palm beach','whatsnew']);
	googletag.pubads().setTargeting('UGC', ['no']);
	
  });
</script>
<script>
var isHomePage = false;	
// -----------------------------------------------------------------------------------------
// Declare all ads that will be on page.
// -----------------------------------------------------------------------------------------
var gptAdSlots = {};
AdBridg.cmd.push([
		{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-leader1',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320, 100], [320, 50]] },
 { viewport: [729, 400], sizes:  [[728, 90]] },
 { viewport: [1000, 400], sizes:  [[728, 90], [970, 250], [970, 90], [970, 415]] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['Leader 1']);
		      gptAdSlots.leader1 = gpt_slot;
		    }
		  }
		},
					{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-box1',
		  size_map: [
		   { viewport: [0, 0], sizes: [[300, 250]] },
 { viewport: [729, 400], sizes:  [[300, 1050],[300, 600],[300, 250]] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['Box 1']);
		      gptAdSlots.box1 = gpt_slot;
		    }
		  }
		},
				{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-box2',
		  size_map: [
		   { viewport: [0, 0], sizes: [[300, 250]] },
 { viewport: [729, 400], sizes:  [[300, 1050],[300, 600],[300, 250]] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['Box 2']);
		      gptAdSlots.box2 = gpt_slot;
		    }
		  }
		},
				{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-box3',
		  size_map: [
		   { viewport: [0, 0], sizes: [[300, 250]] },
 { viewport: [729, 400], sizes:  [[300, 1050],[300, 600],[300, 250]] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['Box 3']);
		      gptAdSlots.box3 = gpt_slot;
		    }
		  }
		},
					{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-inarticle1',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320,100],[300, 250]] },
 { viewport: [729, 400], sizes:  [] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['In Article 1']);
		      gptAdSlots.inarticle1 = gpt_slot;
		    }
		  }
		},
				{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-inarticle2',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320,100],[300, 250]] },
 { viewport: [729, 400], sizes:  [] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['In Article 2']);
		      gptAdSlots.inarticle2 = gpt_slot;
		    }
		  }
		},
				{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-inarticle3',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320,100],[300, 250]] },
 { viewport: [729, 400], sizes:  [] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['In Article 3']);
		      gptAdSlots.inarticle3 = gpt_slot;
		    }
		  }
		},
				{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-inarticle4',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320,100],[300, 250]] },
 { viewport: [729, 400], sizes:  [] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['In Article 4']);
		      gptAdSlots.inarticle4 = gpt_slot;
		    }
		  }
		},
				{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-inarticle5',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320,100],[300, 250]] },
 { viewport: [729, 400], sizes:  [] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['In Article 5']);
		      gptAdSlots.inarticle5 = gpt_slot;
		    }
		  }
		},
				{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-inarticle6',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320,100],[300, 250]] },
 { viewport: [729, 400], sizes:  [] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['In Article 6']);
		      gptAdSlots.inarticle6 = gpt_slot;
		    }
		  }
		},
					{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-inline1',
		  size_map: [
		   { viewport: [0, 0], sizes: [[320,100],[320, 50]] },
 { viewport: [729, 400], sizes:  [] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['Inline 1']);
		      gptAdSlots.inline1 = gpt_slot;
		    }
		  }
		},
					{
		  gpt_path: '/4564944/gaycities/article',
		  dom_id:   'div-gpt-ad-sponsorship1',
		  size_map: [
		   { viewport: [0, 0], sizes: [[120, 90]] },
		  ],
		  events: {
		    "gpt.defined": function(gpt_slot) {
				gpt_slot.setTargeting('ad-location',['Sponsorship 1']);
		      gptAdSlots.sponsorship1 = gpt_slot;
		    }
		  }
		},
				
]);	//close ad units cmd.push
</script><title>West Palm Beach honors gay bar as a landmark site of historic interest / GayCities Blog</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//q-digital.videoplayerhub.com' />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//www.gaycities.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="GayCities Blog &raquo; Feed" href="https://www.gaycities.com/outthere/feed/" />
<link rel="alternate" type="application/rss+xml" title="GayCities Blog &raquo; Comments Feed" href="https://www.gaycities.com/outthere/comments/feed/" />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.gaycities.com/outthere/wp/wp-includes/css/dist/block-library/style.min.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css-css' href='https://www.gaycities.com/outthere/content/themes/gaycities_2017/fonts/font-awesome-4.7.0/font-awesome.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='gaycities-site-style-css' href='https://www.gaycities.com/css/style.css?ver=20200305b' type='text/css' media='all' />
<link rel='stylesheet' id='gaycities_2017-style-css' href='https://www.gaycities.com/outthere/content/themes/gaycities_2017/style.css?ver=20200305b' type='text/css' media='all' />
<script type='text/javascript' src='https://www.gaycities.com/outthere/wp/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.gaycities.com/outthere/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdn.jsdelivr.net/jquery.slick/1.6.0/slick.min.js?ver=20170107' id='slick-js'></script>
<link rel="canonical" href="https://www.gaycities.com/outthere/53342/west-palm-beach-honors-gay-bar-landmark-site-historic-interest/" />
<meta property="og:site_name" content="GayCities Blog" /> <meta name="description" content="The city of West Palm Beach in South Florida has added a long-running LGBTQ bar, HG Roosters, to its Register of Historic Places. It makes it the only gay venue in Florida to be recognized as a designated historic site, and only the third in the U.S., after the Stonewall Inn in New..." />
<meta property="og:description" content="The city of West Palm Beach in South Florida has added a long-running LGBTQ bar, HG Roosters, to its Register of Historic Places. It makes it the only gay venue in Florida to be recognized as a designated historic site, and only the third in the U.S., after the Stonewall Inn in New...">
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.gaycities.com/outthere/53342/west-palm-beach-honors-gay-bar-landmark-site-historic-interest/" />
<meta property="og:title" content="West Palm Beach honors gay bar as a landmark site of historic interest" />
<meta property="og:image" content="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/roosters_pride_2018_facebook.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=1024&h=576" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta name="twitter:image" content="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/roosters_pride_2018_facebook.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=1024&h=576" />
<meta property="article:published_time" content="2021-04-08T13:11:35-04:00" />
<meta property="article:modified_time" content="2021-04-08T13:18:07-04:00" />
<meta name="twitter:url" content="https://www.gaycities.com/outthere/53342/west-palm-beach-honors-gay-bar-landmark-site-historic-interest/" />
<meta name="twitter:title" content="West Palm Beach honors gay bar as a landmark site of historic interest" />
<meta name="twitter:description" content="The city of West Palm Beach in South Florida has added a long-running LGBTQ bar, HG Roosters, to its Register of Historic Places. It makes it the only gay venue in Florida to be recognized as a designated historic site, and only the third in the U.S., after the Stonewall Inn in New..." />
<meta name="news_keywords" content="florida, HG Roosters, West Palm Beach"><meta property="article:tags" content="florida, HG Roosters, West Palm Beach"><meta name="author" property="author" content="David Hudson" /> 
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-KXLC6M6');</script>

<link rel="amphtml" href="https://www.gaycities.com/outthere/53342/west-palm-beach-honors-gay-bar-landmark-site-historic-interest/?amp"> <meta property="fb:app_id" content="203568195269" />
<meta property="article:publisher" content="http://www.facebook.com/gaycities" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@gaycities" />
<meta name="apple-itunes-app" content="app-id=303661699">
<meta name="apple-mobile-web-app-title" content="gaycities">
<meta name="application-name" content="GayCities">
<meta name="theme-color" content="#ffffff">
</head>
<body class="post-template-default single single-post postid-53342 single-format-standard category-whatsnew">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KXLC6M6"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div id="page" class="site">
<div class="gaycities-header-ad" id="div-gpt-ad-leader1">
<script>
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-leader1'); });
				</script>
</div>

<div id="is-phone"></div>
<header class="site-header" role="banner">
<div class="top-navigation">
<div class="site-header-inner-wrap">
<nav class="site-header-inner clearfix">
<a class="logo" href="https://www.gaycities.com">
<img src="https://www.gaycities.com/images/gaycities-logo.svg" alt="GayCities Gay Travel Guides">
</a>
<div class="caret-wrapper">
<span class="caret" data-dropdown="toggle" aria-haspopup="true" aria-expanded="false" aria-controls="mobile-dropdown-menu"></span>
</div>
<ul class="header-left-nav">
<li><a href="https://www.gaycities.com/places" class="">Cities</a></li>
<li><a href="https://www.gaycities.com/articles" class="selected">Articles</a></li>
<li><a href="https://www.gaycities.com/photos">Photos</a></li>
</ul>
<ul class="mobile-dropdown-menu" id="mobile-dropdown-menu" data-dropdown="menu" aria-hidden="true" aria-label="User Account Dropdown Menu">
<li><a href="https://www.gaycities.com">Home</a></li>
<li><hr></li>
<li><a href="https://www.gaycities.com/places" class="">Cities</a></li>
<li><a href="https://www.gaycities.com/articles" class="selected">Articles</a></li>
<li><a href="https://www.gaycities.com/photos">Photos</a></li>
<li><hr></li>
<li><a href="https://www.gaycities.com/login">Sign In</a></li>
<li><a href="https://www.gaycities.com/register">Register</a></li>
</ul>
</nav>
</div>
</div>
</header>
<div id="content" class="site-content"> <div id="primary" class="content-area single-article">
<main id="main" class="site-main" role="main">
<article id="post-53342" class="post-53342 post type-post status-publish format-standard has-post-thumbnail hentry category-whatsnew tag-florida tag-hg-roosters tag-west-palm-beach">
<header class="entry-header">
<h1 class="entry-title"><a href="https://www.gaycities.com/outthere/53342/west-palm-beach-honors-gay-bar-landmark-site-historic-interest/">West Palm Beach honors gay bar as a landmark site of historic interest</a></h1>
<div class="entry-meta">
<span class="byline"> By <a href="https://www.gaycities.com/outthere/author/david-hudson/" title="Posts by David Hudson" rel="author">David Hudson</a></span> <time class="posted-on" datetime="2021-04-08T13:11:35-04:00">1 hour ago</time> </div>
</header>
<div class="entry-content">
<small><i>GayCities encourages you to stay safe during the Covid 19 pandemic. If you choose to travel, we recommend that you follow all <a href="https://www.cdc.gov/coronavirus/2019-ncov/travelers/travel-during-covid19.html">CDC Travel Guidelines</a> and adhere closely to all local regulations regarding face coverings, social distancing and other safety measures.</i></small><br><br>
<script data-cfasync="false" type="text/javascript" class="teads" async="true" src="//a.teads.tv/page/74317/tag"></script><script data-cfasync="false" src="//a.teads.tv/media/format/v3/teads-format.min.js"></script><figure id="attachment_53359" aria-describedby="caption-attachment-53359" style="width: 960px" class="wp-caption aligncenter"><img loading="lazy" class="wp-image-53359 size-full" src="https://gaycities-blog-prodweb.s3.amazonaws.com/outthere/content/uploads/2021/04/roosters_pride_2018_facebook.jpg" alt="The HG Roosters marchers at West Palm Beach Pride, 2018" width="960" height="509" srcset="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/roosters_pride_2018_facebook.jpg?&amp;auto=format&amp;auto=compress&amp;w=960 960w, https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/roosters_pride_2018_facebook.jpg?&amp;auto=format&amp;auto=compress&amp;w=550 550w, https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/roosters_pride_2018_facebook.jpg?&amp;auto=format&amp;auto=compress&amp;w=768 768w, https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/roosters_pride_2018_facebook.jpg?&amp;auto=format&amp;auto=compress&amp;w=396 396w" sizes="(max-width: 960px) 100vw, 960px"><figcaption id="caption-attachment-53359" class="wp-caption-text">The HG Roosters contingent at West Palm Beach Pride, 2018 (Photo: HG Roosters)</figcaption></figure>
<p>The city of <a href="https://westpalmbeach.gaycities.com/">West Palm Beach</a> in South Florida has added a long-running LGBTQ bar, HG Roosters, to its Register of Historic Places.</p>
<p>It makes it the only gay venue in Florida to be recognized as a designated historic site, and only the third in the U.S., after the Stonewall Inn in New York City and <a href="https://www.ajc.com/news/atlanta-news/iconic-atlanta-eagle-gay-bar-to-get-historic-landmark-designation-from-city/HQW6TGKUJZASDAIKWOKRQRGLD4/" target="_blank" rel="noopener">Atlanta Eagle in Atlanta</a>.</p>
<figure id="attachment_53357" aria-describedby="caption-attachment-53357" style="width: 1200px" class="wp-caption aligncenter"><img loading="lazy" class="wp-image-53357 size-full" src="https://gaycities-blog-prodweb.s3.amazonaws.com/outthere/content/uploads/2021/04/hg_roosters_google_maps_2019.jpg" alt="HG Roosters in 2019 " width="1200" height="520" srcset="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/hg_roosters_google_maps_2019.jpg?&amp;auto=format&amp;auto=compress&amp;w=1200 1200w, https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/hg_roosters_google_maps_2019.jpg?&amp;auto=format&amp;auto=compress&amp;w=550 550w, https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/hg_roosters_google_maps_2019.jpg?&amp;auto=format&amp;auto=compress&amp;w=1024 1024w, https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/hg_roosters_google_maps_2019.jpg?&amp;auto=format&amp;auto=compress&amp;w=768 768w, https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/hg_roosters_google_maps_2019.jpg?&amp;auto=format&amp;auto=compress&amp;w=396 396w" sizes="(max-width: 1200px) 100vw, 1200px"><figcaption id="caption-attachment-53357" class="wp-caption-text">HG Roosters in 2019 (Image: Google Maps)</figcaption></figure>
<p>HG Roosters can be found at 823 Belvedere Road. In the motion to recognize its importance, it was noted that “the site has been a safe gathering space for the LGBTQ community for over 60 years. It has also been instrumental in being a leader in philanthropic efforts on behalf of the AIDS pandemic, Breast Cancer and other charities, as well as sponsoring various gay pride initiatives.”</p><div class="ad-300 inline" id="div-gpt-ad-inarticle1"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle1"); });</script></div>
<p><strong>Related: <a href="https://www.gaycities.com/outthere/53305/iconic-san-francisco-gay-bar-reopens-shuttered-year/">Iconic San Francisco gay bar reopens after being shuttered for a year</a></strong></p>
<p>Roosters dates back to 1984, but previous to this it was known under different names, including Turf West in the 1960s.</p>
<p>The historic preservation board previously agreed to the designation in March, but it came before the city commission for a vote on Monday (April 5).</p>
<p>Afterward, owner A.J. Wasson said, “This evening’s vote was unanimous. It’s a huge honor to be recognized. Our hearts are full,” reports <a href="https://southfloridagaynews.com/Local/h-g-rooster-s-is-now-a-west-palm-beach-historic-site.html" target="_blank" rel="noopener">South Florida Gay News</a>.</p><div class="ad-300 inline" id="div-gpt-ad-inarticle2"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle2"); });</script></div>
<p>“Rooster’s has a legacy of giving and caring and this designation will cement that legacy well into the future after we’re all gone.”</p>
<figure id="attachment_53358" aria-describedby="caption-attachment-53358" style="width: 480px" class="wp-caption aligncenter"><img loading="lazy" class="size-full wp-image-53358" src="https://gaycities-blog-prodweb.s3.amazonaws.com/outthere/content/uploads/2021/04/hg_roosters_glow_night.jpg" alt="" width="480" height="539" srcset="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/hg_roosters_glow_night.jpg?&amp;auto=format&amp;auto=compress&amp;w=480 480w, https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/hg_roosters_glow_night.jpg?&amp;auto=format&amp;auto=compress&amp;w=251 251w" sizes="(max-width: 480px) 100vw, 480px"><figcaption id="caption-attachment-53358" class="wp-caption-text">‘Glow night’ at HG Roosters, pre-pandemic (Photo: Supplied)</figcaption></figure>
<p>Sadly, Rooster’s suffered a dreadful fire last May, a few weeks after shuttering because of the pandemic. It destroyed the kitchen and some of the roof, with water and smoke damage throughout the rest of the venue. As it was closed at the time, and facing mounting debts, the owners decided to prioritize paying employees and had stopped paying their insurance in April.</p>
<p>Facing a huge repairs bill, it set up a <a href="https://www.gofundme.com/f/roosters-fire-fundraiser">GoFundMe</a> for help. It’s raised $59,000 of a $100,000 target.</p><div class="ad-300 inline" id="div-gpt-ad-inarticle3"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle3"); });</script></div>
<figure id="attachment_53363" aria-describedby="caption-attachment-53363" style="width: 960px" class="wp-caption aligncenter"><img loading="lazy" class="size-full wp-image-53363" src="https://gaycities-blog-prodweb.s3.amazonaws.com/outthere/content/uploads/2021/04/roosters_fire_shell_supplied.jpg" alt="HG Roosters suffered a devastating fire last year, leaving it a burned-out shell" width="960" height="705" srcset="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/roosters_fire_shell_supplied.jpg?&amp;auto=format&amp;auto=compress&amp;w=960 960w, https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/roosters_fire_shell_supplied.jpg?&amp;auto=format&amp;auto=compress&amp;w=550 550w, https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/roosters_fire_shell_supplied.jpg?&amp;auto=format&amp;auto=compress&amp;w=768 768w, https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/roosters_fire_shell_supplied.jpg?&amp;auto=format&amp;auto=compress&amp;w=384 384w" sizes="(max-width: 960px) 100vw, 960px"><figcaption id="caption-attachment-53363" class="wp-caption-text">HG Roosters suffered a devastating fire last year, leaving it a burned-out shell (Photo: Supplied)</figcaption></figure>
<p><strong>Related: <a href="https://www.gaycities.com/outthere/52483/10-oldest-iconic-gay-bars-us/">10 of the oldest and most iconic gay bars in the US</a></strong></p>
<p>Wasson says the venue will definitely reopen and architects have now finalized rebuilding plans. The stone-clad exterior will remain as it is, but the interior will be greatly changed. He’s estimating construction work will take another six months and is aiming for a fall or early winter reopening. He believes the new historic designation will help with the reopening plans and the permit process.</p>
<p>Wasson told GayCities, “With this historic designation the city of West Palm Beach sent a strong and clear message to its LGBTQ+ citizens. That message is, ‘we see you, we embrace you and your history is our history’.”</p><div class="ad-300 inline" id="div-gpt-ad-inarticle4"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle4"); });</script></div>
<p>At the same meeting on Monday, the city commission approved the construction of a rainbow crosswalk at the intersection of Northwood Road and Spruce Avenue, in the Northwood Village neighborhood. It’s hoped the crosswalk will be in place for Pride month.</p>
<p><strong>Related: <a href="https://www.gaycities.com/outthere/52885/insiders-guide-key-west-gay-men-love-much-moved/">The insider’s guide to Key West – from the gay men who love it so much they moved there</a></strong></p>
</div>
<footer class="entry-footer">
<span class="tags-links"><a href="https://www.gaycities.com/outthere/tag/florida/" rel="tag">florida</a> <a href="https://www.gaycities.com/outthere/tag/hg-roosters/" rel="tag">HG Roosters</a> <a href="https://www.gaycities.com/outthere/tag/west-palm-beach/" rel="tag">West Palm Beach</a></span> </footer>
</article>
<div class="mobile-ad-leader" id="div-gpt-ad-inline1">
<script>
	AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-inline1'); });
	</script>
</div>
<div class="fb-comments" data-href="https://www.gaycities.com/outthere/53342/west-palm-beach-honors-gay-bar-landmark-site-historic-interest/" data-numposts="10"></div>
</main>
</div>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-596fbbbe85709b4a"></script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.gaycities.com\/outthere\/53342\/west-palm-beach-honors-gay-bar-landmark-site-historic-interest\/"},"headline":"West Palm Beach honors gay bar as a landmark site of historic interest","url":"https:\/\/www.gaycities.com\/outthere\/53342\/west-palm-beach-honors-gay-bar-landmark-site-historic-interest\/","datePublished":"2021-04-08T13:11:35-04:00","dateModified":"2021-04-08T13:18:07-04:00","description":"The city of West Palm Beach in South Florida has added a long-running LGBTQ bar, HG Roosters, to its Register of Historic Places. It makes it the only gay venue in Florida to be recognized as a designated historic site, and only the third in the U.S., after the Stonewall Inn in New York City [&hellip;]","thumbnailUrl":"https:\/\/gaycities-blog-prodweb.s3.amazonaws.com\/outthere\/content\/uploads\/2021\/04\/roosters_pride_2018_facebook-396x210.jpg","image":{"@type":"ImageObject","url":"https:\/\/gaycities-blog-prodweb.s3.amazonaws.com\/outthere\/content\/uploads\/2021\/04\/roosters_pride_2018_facebook-396x210.jpg","height":872,"width":462},"creator":"David Hudson","author":{"@type":"Person","name":"David Hudson"},"articleSection":"Articles","keywords":["florida","HG Roosters","West Palm Beach","[ Word count: 300-600 ]"],"publisher":{"@type":"NewsMediaOrganization","name":"Queerty","url":"https:\/\/www.gaycities.com\/","logo":{"@type":"ImageObject","url":"https:\/\/www.gaycities.com\/images\/gaycities-logo-blue.png","height":"198","width":"855"},"address":{"@type":"PostalAddress","streetAddress":"584 Castro St. #623","addressLocality":"San Francisco","addressRegion":"CA","postalCode":"94114","addressCountry":"USA"},"sameAs":["https:\/\/www.facebook.com\/gaycities","https:\/\/www.twitter.com\/gaycities","https:\/\/www.instagram.com\/gaycities"]}}</script>
<aside id="secondary" class="article-sidebar" role="complementary">
<div class="sidebar-ad-1" id="div-gpt-ad-box1">
<script>
			googletag.cmd.push(function() { googletag.display('div-gpt-ad-box1'); });
			</script>
</div>
<section class="sidebar-related">
<h3 class="category-heading">
More GayCities </h3>
<div class="cards-list">
<article id="post-53324" class="card card-small ">
<a href="https://www.gaycities.com/outthere/53324/saveourspaces-c-frenz-wants-keep-rainbow-flag-flying-reseda/">
<section class="card-thumb">
<img src="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/c_frenz_fence_1200.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">#SaveOurSpaces: C Frenz wants to keep the rainbow flag flying in Reseda</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/53324/saveourspaces-c-frenz-wants-keep-rainbow-flag-flying-reseda/" rel="bookmark"><time class="entry-date published updated" datetime="2021-04-07T12:34:10-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-53316" class="card card-small ">
<a href="https://www.gaycities.com/outthere/53316/new-street-art-san-francisco-honors-sisters-perpetual-indulgence/">
<section class="card-thumb">
<img src="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/Screen-Shot-2021-04-07-at-1.17.53-PM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">New street art in San Francisco honors the Sisters of Perpetual Indulgence</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/53316/new-street-art-san-francisco-honors-sisters-perpetual-indulgence/" rel="bookmark"><time class="entry-date published updated" datetime="2021-04-06T08:30:21-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-53305" class="card card-small ">
<a href="https://www.gaycities.com/outthere/53305/iconic-san-francisco-gay-bar-reopens-shuttered-year/">
<section class="card-thumb">
<img src="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/Screen-Shot-2021-04-07-at-1.24.19-PM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">Iconic San Francisco gay bar reopens after being shuttered for a year</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/53305/iconic-san-francisco-gay-bar-reopens-shuttered-year/" rel="bookmark"><time class="entry-date published updated" datetime="2021-04-01T17:05:00-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-53202" class="card card-small ">
<a href="https://www.gaycities.com/outthere/53202/vincent-rommelaere-documenting-burning-man-sydney-mardi-gras-time-covid/">
<section class="card-thumb">
<img src="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/Screen-Shot-2021-04-01-at-3.40.05-PM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">Vincent Rommelaere on Sydney Mardi Gras in the time of Covid</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/53202/vincent-rommelaere-documenting-burning-man-sydney-mardi-gras-time-covid/" rel="bookmark"><time class="entry-date published updated" datetime="2021-04-01T08:15:06-04:00"></time></a> </div>
</section>
</a>
</article>
</div>
</section>
<div class="sidebar-ad-2" id="div-gpt-ad-box2">
<script>
			googletag.cmd.push(function() { googletag.display('div-gpt-ad-box2'); });
			</script>
</div>
<div id="civsci-id-109286964" data-civicscience-widget="a8ff42a5-6a5e-8114-ed3f-8851c8882960"></div>
<script type="text/javascript" async src="https://www.civicscience.com/jspoll/4/civicscience-widget.js"></script>
</aside>
<br clear=all>
<div class="single-bottom-articles">
<h3>
Latest Travel Articles on GayCities </h3>
<div class="single-bottom-articles-slider slider slick-slider">
<div>
<article id="post-53324" class="card card-small ">
<a href="https://www.gaycities.com/outthere/53324/saveourspaces-c-frenz-wants-keep-rainbow-flag-flying-reseda/">
<section class="card-thumb">
<img src="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/c_frenz_fence_1200.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">#SaveOurSpaces: C Frenz wants to keep the rainbow flag flying in Reseda</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/53324/saveourspaces-c-frenz-wants-keep-rainbow-flag-flying-reseda/" rel="bookmark"><time class="entry-date published updated" datetime="2021-04-07T12:34:10-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div>
<article id="post-53316" class="card card-small ">
<a href="https://www.gaycities.com/outthere/53316/new-street-art-san-francisco-honors-sisters-perpetual-indulgence/">
<section class="card-thumb">
<img src="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/Screen-Shot-2021-04-07-at-1.17.53-PM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">New street art in San Francisco honors the Sisters of Perpetual Indulgence</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/53316/new-street-art-san-francisco-honors-sisters-perpetual-indulgence/" rel="bookmark"><time class="entry-date published updated" datetime="2021-04-06T08:30:21-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div>
<article id="post-53305" class="card card-small ">
<a href="https://www.gaycities.com/outthere/53305/iconic-san-francisco-gay-bar-reopens-shuttered-year/">
<section class="card-thumb">
<img src="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/Screen-Shot-2021-04-07-at-1.24.19-PM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">Iconic San Francisco gay bar reopens after being shuttered for a year</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/53305/iconic-san-francisco-gay-bar-reopens-shuttered-year/" rel="bookmark"><time class="entry-date published updated" datetime="2021-04-01T17:05:00-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div>
<article id="post-53202" class="card card-small ">
<a href="https://www.gaycities.com/outthere/53202/vincent-rommelaere-documenting-burning-man-sydney-mardi-gras-time-covid/">
<section class="card-thumb">
<img src="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/04/Screen-Shot-2021-04-01-at-3.40.05-PM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">Vincent Rommelaere on Sydney Mardi Gras in the time of Covid</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/53202/vincent-rommelaere-documenting-burning-man-sydney-mardi-gras-time-covid/" rel="bookmark"><time class="entry-date published updated" datetime="2021-04-01T08:15:06-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div>
<article id="post-53295" class="card card-small ">
<a href="https://www.gaycities.com/outthere/53295/saveourspaces-wildrose-one-remaining-lesbian-bars-u-s/">
<section class="card-thumb">
<img src="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/03/wildrose_bar_instagram_1200.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">#SaveOurSpaces: Wildrose is one of the few remaining lesbian bars in the U.S.</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/53295/saveourspaces-wildrose-one-remaining-lesbian-bars-u-s/" rel="bookmark"><time class="entry-date published updated" datetime="2021-03-31T06:55:32-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div>
<article id="post-53284" class="card card-small ">
<a href="https://www.gaycities.com/outthere/53284/white-party-palm-springs-postponed-april-halloween/">
<section class="card-thumb">
<img src="https://i.gaycities.com/v7/_gc-blog-prodweb_/outthere/content/uploads/2021/03/white_party_iggy_lopez_trio_1200.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">White Party Palm Springs postponed from April to Halloween</h2> <div class="entry-meta">
<a href="https://www.gaycities.com/outthere/53284/white-party-palm-springs-postponed-april-halloween/" rel="bookmark"><time class="entry-date published updated" datetime="2021-03-30T09:24:32-04:00"></time></a> </div>
</section>
</a>
</article>
</div>
</div>
</div>
</div>
<div class="site-footer-holder">
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="footer-links">
<ul class="main" id="footer-company-links">
<li><a href="https://www.q.digital"><img src="https://dxepcgbfdydik.cloudfront.net/assets/q-digital-blue-90x37.png" alt="Q.Digital" width="90"></a></li>
<li><b>A Q.Digital Company</b></li>
<li>&copy; 2021 GayCities, Inc.</li>
<li><a href="https://www.q.digital">Advertise With Us</a></li>
</ul>
<ul class="main" id="footer-contact-links">
<li><a href="https://www.gaycities.com/about/privacy">Privacy Policy</a>
<li><a href="https://www.gaycities.com/about/termsofuse">Terms of Use</a>
</ul>
<ul class="main" id="footer-follow-links">
<li><h3>Follow</h3></li>
<li><a href="https://www.facebook.com/GayCities/">Facebook</a></li>
<li><a href="https://www.twitter.com/GayCities/">Twitter</a></li>
<li><a href="https://www.instagram.com/GayCities/">Instagram</a></li>
</ul>
<ul class="main double" id="footer-gaycities-links">
<li><h3>GayCities: The best of what's happening in:</h3></li>
<li><a href="https://newyork.gaycities.com/">New York</a></li>
<li><a href="https://sanfrancisco.gaycities.com/">San Francisco</a></li>
<li><a href="https://chicago.gaycities.com/">Chicago</a></li>
<li><a href="https://losangeles.gaycities.com/">Los Angeles</a></li>
<li><a href="https://washingtondc.gaycities.com/">Washington DC</a></li>
<li><a href="https://dallas.gaycities.com/">Dallas</a></li>
<li><a href="https://london.gaycities.com/">London</a></li>
<li><a href="https://www.gaycities.com/places/"><b>See all 225+ cities...</b></a></li>
</ul>
</div>
</footer>
</div>
</div>

<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "32666898" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=32666898&cv=2.0&cj=1" alt="Comscore Measurement" />
</noscript>

<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '686853021424163');
  fbq('track', 'PageView');
</script>
<noscript><img height='1' width='1' style='display:none'
  src='https://www.facebook.com/tr?id=686853021424163&ev=PageView&noscript=1'
/></noscript>

<script>
  fbq('track', 'ViewContent');
</script>
<script type='text/javascript' src='https://q-digital.videoplayerhub.com/galleryplayer.js?ver=20210329' id='bt-js'></script>
<script type='text/javascript' src='https://www.gaycities.com/outthere/content/themes/gaycities_2017/js/gaycities-main-min.js?ver=20170926' id='gaycities_2017-main-js'></script>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=20161216' id='twitter-js-js'></script>
<script type='text/javascript' src='https://www.gaycities.com/outthere/wp/wp-includes/js/wp-embed.min.js?ver=5.7' id='wp-embed-js'></script>
<div id="fb-root"></div>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.3&appId=203568195269&autoLogAppEvents=1"></script>
<script data-cfasync="false" id="parsely-cfg" data-parsely-site="gaycities.com" src="https://cdn.parsely.com/keys/gaycities.com/p.js"></script>
</body>
</html>